WordPressテーマのインストールに失敗

今までデフォルトのWordPressテーマ、Twenty Twenty-Oneを使用していたのですが、あまりにも殺風景なので、評判が良さそうなCocoonをインストールしようとしたところ、”辿ったリンクは期限が切れています。もう一度お試しください。”というエラーが発生しました。無事解決出来たので、原因と解決方法をメモしたいと思います。

本サイトですが、VPS上でWordPress dockerを動かして運営しています。調べたところ、このdockerで設定されている、アップロードファイルの上限サイズがデフォルトだと2MBとなっており、一方でCocoonテーマファイルは14.7MBなので、上限に引っかかりエラーとなっていました。

uploads.iniというファイルを以下の内容で作成、docker-compose.yml wordpressのvolumesに同ファイルを追加する事で上限を引き上げる事が出来、テーマインストールにも成功しました。

upload_max_filesize = 50M;
post_max_size = 50M;

通常は画像ファイルのアップロードで引っかかるようですが、いつもサイズ縮小しているので、今回のテーマインストールで発覚という事になったのでした。

コメント

タイトルとURLをコピーしました